myQBCC system requirements and useful tips

Browser

The security features in myQBCC that help protect your information can only operate in modern browsers, so you’ll need one of the following:

  • Apple Safari version 12 (or latest version)
  • Mozilla Firefox (latest version)
  • Google Chrome (latest version)
  • Internet Explorer version 11
  • Microsoft Edge version 18 (or latest version)

 Some aspects of myQBCC won’t work correctly on outdated browsers. If you haven’t updated for a while or you can’t remember when you last did, you should check for browser updates.

Viewing myQBCC on Apple devices

myQBCC is available on Apple devices however is not optimised.

Enable JavaScript

myQBCC uses JavaScript to ensure features work for you as they were designed to. Enabling JavaScript in your browser needs to be carried out if it hasn’t yet been done.

Accept cookies

“Cookies” are small amounts of data that allow myQBCC to remember important information, such as preference settings for your account. myQBCC requires cookies enabled.

Enable TLS 1.1 (or higher) security settings

TLS 1.1 (or higher) settings help protect personal credit card information as it is processed through your browser. Browsers that don’t have these settings enabled won’t be able to access myQBCC to make a payment.

Clear your cache

Clearing your cache can help your browser display fresh webpage information. If you are experiencing loading or formatting issues with myQBCC, try refreshing your cache.

Still not working for you?

If the above troubleshooting steps don’t resolve your problem, send a screenshot with a short description through to Feedback and Enquiries. It will help us understand your specific issue.

You can also call us directly on 139 333.